wiki:Old/WiMAX/20
close Warning: Can't synchronize with repository "(default)" (/common/SVN/wimax does not appear to be a Subversion repository.). Look in the Trac log for more information.

Version 11 (modified by hmussman, 10 years ago) ( diff )

B. Errata/ Things we had to change but haven't formally committed to documentation

10/11/2010

We're going down the list of wiki:WiMAX/Software/Configuration and editing all the files accordingly.

  • on the console machine (10.3.7.254 in this case), we edited /usr/share/asngw/classify-ctrl.sh, we changed the lines:
    Changed:
    : ${DEV_R3:="eth0"}
    : ${DEV_R6R4:="eth1"}
    : ${DEV_GREALL:="gre+"}
    : ${DEV_MSTUN:="mstun"}
    
    : ${MS2MS:="DROP"}
    : ${MS2MS_GRE_OPT:=""}
    : ${MS2MS_MSTUN_OPT:="-p icmp"}
    : ${MSMARK:="0x100"}
    
    : ${MSADDR:="10.41.0.0/16"}
    : ${R3_NETWORK:="10.41.0.0/16"}
    : ${R3_ADDR:="10.41.0.3"}  #jml
    : ${R6R4_NETWORK:="10.3.0.0/16"}
    : ${R6R4_ADDR:="10.3.7.1"}  # jml
    
  • editing the /etc/asnctrl.conf
    Changed:
    R6_BSID[0] = 44:51:DB:00:07:01
    R6_BSAddress[0] = [10.3.7.1]:2231
    TunnelEndpoint = [10.3.7.254]:0
    
  • editing the /etc/asnctrl_ASNGW000.conf
    Changed
    R4_BSID[0][0]=44:51:DB:00:07:01
    
  • /etc/epctr.conf
    R3LocalDevice = eth0
    R4LocalDevice = eth1
    R6LocalDevice = eth1
    

We discovered an error in the wiset commands. Apparently the IP of the authgw_ip and associated flags needs to be set to the IP of the consoles eth1 intefaces (the one in the BS subnet). I had it incorrectly set to point to it self.

wiset authgw_ip 0x0A0307FE
wiset asngw_dp_ip 0x0A0307FE
wiset asngw_ep_ip 0x0A0307FE

Was run.


We copied SAMrb (cons-wm-01:/root/Oldhome/SAMrb_Oct7_2010.tar) from cons-wm-01 to the /root of the console and untarred it. We then installed rubygems and the open4 and orderedhash gems.

240  apt-get install rubygems
242  gem install open4
243  gem install orderedhash

From here we run the simple authmanager, it's interpreted by the ruby interpreter.

root@wimax:/root/SAMrb# ruby SimpleAuthManager.rb
Writting to a file
Started click PID=4633

The last step is to check if connectivity work by associating a wimax client. NOTE the power of the ODU connected to the test BS is very low, the client should be very close to the antenna, and the other BS (ours) must be turned off.

On the client (imaged with appropriate drivers, wimax utils, etc.. ), run

wimaxcu ron - turns on the raido
wimaxcu scan - scans for the BS
wimaxcu connect profile 51

you should see a connected message.

If you want to reset the radio run:

wimaxcu ron
wimaxcu roff

10/12/2010

In order to connect to the serial console for managment, you'll need a straight through (not null) serial cable that connects male to female. You'll also need mini-com Installed (apt-get-able). From the default mini-com install, edit the config (ctrl-a, o) and change the default port to /dev/ttyS0. The default transmit paramters are ok, 115200,8,N,1. You will howerver need to disable hardware flow control to talk to the DSP machine. Save these as a default.

I noticed from the original installation notes that there was a file we didn't change, which we modify during installation. /etc/omf-aggmgr-5.2/available/wimaxrf.yaml. I'm noting here that moving forward I'll make this file agree with the rest of the files, this may present a problem in some of our depolyments since some were shipped with this file in the installed state.

If everything looks ok and the client is still not able to connect to the BTS due to range response failures, please ensure that the ODU noise floor is setup appropriately. This can be done by using the following command on the IDU:

wiset odu_noise_floor 40
Note: See TracWiki for help on using the wiki.